Linux 命令行切换php默认版本

我们用到的比如宝塔可以安装多个PHP的版本,但是有些地方,比如执行计划任务,执行shell脚本命令时会使用一个默认的PHP版本,比如网站版本为7.2,这个时候用默认的5.6执行命令就会出错。这个时候我们就需要用到切换PHP默认的版本。

通过SSH连接远程服务器,删除默认的PHP版本,切记如果没有输入路径直接rm -f 那么你服务器资料就完了。

rm -f /usr/bin/php

再输入以下命令,指定默认PHP版本,比如7.1

ln -sf /www/server/php/71/bin/php /usr/bin/php

免责声明:本站所提供的资源和内容部分来源于互联网及网友投稿,仅供学习和研究,请勿用于非法商业用途!如产生的任何法律纠纷与违法行为与本站无关!如有侵权请联系我们处理,敬请谅解! 购买产品的客户请勿涉黄或其他违反国家法律的用途上,如有客户不遵守国家法律产生相关法律问题与本站无关,我们不接触一切违反国家法律的技术支持工作,使用产品后请正确正规经营程序!

没有账号? 注册  忘记密码?